Back to overview
Maintenance

Scheduled Maintenance Notice

May 25 at 05:00pm CEST  –  May 26 at 02:01am CEST
Affected services
API Server
Game Site

Resolved
May 26 at 02:01am CEST

✅ The scheduled maintenance has now been successfully completed.

If you experience any performance issues or notice anything not working as expected, please don’t hesitate to reach out to us via our Discord server or email us at help@rhythm-plus.com.

Thanks for your patience and support! ❤️

Created
May 25 at 05:00pm CEST

Rhythm Plus will be undergoing maintenance tomorrow (May 25th) starting at around 8:00 AM PDT and lasting throughout the day.

🛠️ This is to prepare for a major upcoming update—stay tuned!

We appreciate your patience and understanding. ❤️